CVE-2025-55203: makeplane plane · Cross-site Scripting
Affects makeplane planeSource CVE Database V5
Not known to be exploited · CVSS 5.4 Medium : upgrade to 0.28.0 when convenient.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.28.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 15 Aug 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade makeplane plane to 0.28.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| makeplane plane | Affected
| Fixed in
|
AI-suggested
European organizations should immediately upgrade all instances of Plane to version 0.28.0 or later, where the vulnerability has been patched. Until upgrades can be performed, organizations should implement strict input validation and output encoding on the description_html field to prevent malicious scripts from being stored or executed. Employing a Content Security Policy (CSP) that restricts the execution of inline scripts and limits sources of executable code can mitigate the impact of any injected scripts. Additionally, organizations should conduct thorough audits of existing stored descriptions to identify and remove any malicious payloads. User privileges should be reviewed and minimized to reduce the risk of privilege escalation through XSS. Implementing multi-factor authentication (MFA) can help mitigate session hijacking risks. Monitoring web application logs for unusual activity or script injection attempts is recommended to detect exploitation attempts early. Finally, user awareness training about the risks of clicking on suspicious links or interacting with untrusted content within the project management tool can reduce successful exploitation likelihood.
Description
Plane is open-source project management software. Prior to version 0.28.0, a stored cross-site scripting (XSS) vulnerability exists in the description_html field of Plane. This flaw allows an attacker to inject malicious JavaScript code that is stored and later executed in other users’ browsers. The description_html field is not properly sanitized or escaped. An attacker can submit crafted JavaScript payloads that are saved in the application’s database. When another user views the affected content, the injected code executes in their browser, running in the application’s context and bypassing standard security protections. Successful exploitation can lead to session hijacking, theft of sensitive information, or forced redirection to malicious sites. The vulnerability can also be chained with CSRF attacks to perform unauthorized actions, or leveraged to distribute malware and exploit additional browser vulnerabilities. This issue has been patched in version 0.28.0.