CVE-2025-55287: MGeurts genealogy · Cross-site Scripting
Affects MGeurts genealogySource CVE Database V5
Not known to be exploited · CVSS 8.0 High : upgrade to 4.4.0 soon.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 26% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.4.0
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 18 Aug 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade MGeurts genealogy to 4.4.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| MGeurts genealogy | Affected
| Fixed in
|
AI-suggested
Organizations should immediately upgrade the MGeurts genealogy application to version 4.4.0 or later, where the vulnerability is patched. Until the upgrade is applied, implement strict input validation and output encoding on all user-supplied data within the application to prevent script injection. Employ Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts. Conduct regular audits of user-generated content to detect and remove any malicious scripts. Enforce strong authentication mechanisms and monitor for suspicious login activities to reduce the risk of attacker access. Educate users about the risks of clicking on untrusted links or content within the genealogy platform. Additionally, consider isolating the genealogy application environment and restricting access to trusted users only. Implement web application firewalls (WAF) with rules targeting XSS attack patterns to provide an additional layer of defense.
Description
Genealogy is a family tree PHP application. Prior to 4.4.0, Authenticated Stored Cross-Site Scripting (XSS) vulnerability was identified in the Genealogy application. Authenticated attackers could run arbitrary JavaScript in another user’s session, leading to session hijacking, data theft, and UI manipulation. This vulnerability is fixed in 4.4.0.