CVE-2025-5687: Mozilla VPN 2.28.0 · Improper Privilege Management
Affects Mozilla VPN 2.28.0Source CVE Database V5
Not known to be exploited · CVSS 7.8 High : upgrade to 2.28.0 soon.
Data as of 26 Oct 2026, 08:30 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 2% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.28.0
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 11 Jun 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Mozilla VPN 2.28.0 to 2.28.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Mozilla Mozilla VPN 2.28.0 | Affected
| Fixed in
|
AI-suggested
Users should upgrade Mozilla VPN on macOS to version 2.28.0 or later, where this vulnerability has been fixed. No other mitigation is required as the vendor has provided an official fix.
Description
A vulnerability in Mozilla VPN on macOS allows privilege escalation from a normal user to root. *This bug only affects Mozilla VPN on macOS. Other operating systems are unaffected.*. This vulnerability was fixed in Mozilla VPN 2.28.0 (macOS).