Skip to main content
CVE-2025-57817VulnerabilityPublished

CVE-2025-57817: ethyca fides · Missing Authorization

Affects ethyca fidesSource CVE Database V5

0

Not known to be exploited · CVSS 8.6 High : upgrade to 2.69.1 soon.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 4.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.69.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade ethyca fides to 2.69.1.

Affected software

ProductAffectedFixed in
ethyca fidesAffected
  • <2.69.1
Fixed in
  • 2.69.1

AI-suggested

The primary and most effective mitigation is to upgrade all Fides installations to version 2.69.1 or later, where the authorization checks have been properly implemented. Organizations should conduct an immediate inventory of affected Fides instances and prioritize patching. Beyond patching, organizations should enforce strict role-based access controls (RBAC) and audit permissions to ensure that only trusted users have `client:create` or `client:update` privileges, minimizing the risk of privilege escalation. Implementing comprehensive logging and monitoring of OAuth client creation and update activities can help detect anomalous behavior indicative of exploitation attempts. Additionally, organizations should consider network segmentation and access restrictions to limit exposure of the Fides Webserver API to trusted networks and users only. Regular security reviews and penetration testing focused on authorization mechanisms can help identify similar weaknesses proactively. Finally, integrating multi-factor authentication (MFA) for privileged accounts can reduce the risk of credential compromise leading to exploitation.

Description

Fides is an open-source privacy engineering platform. Prior to version 2.69.1, the OAuth client creation and update endpoints of the Fides Webserver API do not properly authorize scope assignment. This allows highly privileged users with `client:create` or `client:update` permissions to escalate their privileges to owner-level. Version 2.69.1 fixes the issue. No known workarounds are available.

References

Community reviews

Loading reviews…