CVE-2025-58175: org.geoserver.web:gs-web-app · Improper Input Validation
Affects org.geoserver.web:gs-web-appSource CVE Database V5
Not known to be exploited · CVSS 6.5 Medium : upgrade to 2.27.3 or 2.26.4 when convenient.
Data as of 1 Nov 2026, 22:57 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.27.3, 2.26.4
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 18 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Upgrade org.geoserver.web:gs-web-app and org.geoserver:gs-main to 2.27.3 or 2.26.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| geoserverorg.geoserver.web:gs-web-app | Affected
| Fixed in
|
| geoserverorg.geoserver.web:gs-web-app | Affected
| Fixed in
|
| geoserverorg.geoserver:gs-main | Affected
| Fixed in
|
| geoserverorg.geoserver:gs-main | Affected
| Fixed in
|
AI-suggested
Upgrade GeoServer to version 2.26.4 or 2.27.3 or later where the vulnerability is fixed. If upgrading is not immediately possible, ensure that the proxy base URL configuration includes a trailing slash if it does not contain a URL path, as this mitigates the vulnerability. No other mitigation steps are specified.
Description
GeoServer is an open source server that allows users to share and edit geospatial data. Prior to versions 2.26.4 and 2.27.3, a GeoServer that uses `ENTITY_RESOLUTION_ALLOWLIST` may allow attacker to perform unauthenticated Server-Side Request Forgery (SSRF). This vulnerability requires that GeoServer is set up to use a proxy base URL and the `ENTITY_RESOLUTION_ALLOWLIST` (default since 2.25.0). Versions 2.26.4 and 2.27.3 contain a fix. GeoServer installations are only affected by this vulnerability if they use a proxy base URL that does not contain a URL path or end with a slash. If the proxy base URL does not contain a path, adding a slash to the end of the URL will mitigate this vulnerability.