CVE-2025-58355: charmbracelet soft-serve · Path Traversal
Affects charmbracelet soft-serveSource CVE Database V5
Not known to be exploited · CVSS 7.7 High : upgrade to 0.10.0 soon.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 27% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.10.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Sep 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade charmbracelet soft-serve to 0.10.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| charmbracelet soft-serve | Affected
| Fixed in
|
AI-suggested
European organizations should immediately identify any deployments of Soft Serve versions below 0.10.0 and upgrade to version 0.10.0 or later, where the vulnerability is fixed. If immediate upgrading is not feasible, organizations should restrict SSH API access to trusted internal networks and enforce strict access controls and monitoring on the Git server. Implementing file integrity monitoring on the server filesystem can help detect unauthorized file modifications. Additionally, organizations should audit repository and server configurations for suspicious changes and review logs for anomalous SSH API usage. Employing network segmentation to isolate Git servers and applying the principle of least privilege to user accounts accessing the SSH API will reduce exploitation risk. Finally, integrating vulnerability scanning into CI/CD pipelines to detect outdated Soft Serve versions can prevent future exposure.
Description
Soft Serve is a self-hostable Git server for the command line. In versions 0.9.1 and below, attackers can create or override arbitrary files with uncontrolled data through its SSH API. This issue is fixed in version 0.10.0.