CVE-2025-58434: FlowiseAI Flowise · Missing Authentication
Affects FlowiseAI FlowiseSource CVE Database V5
Not known to be exploited · public exploit available (Exploit-DB) · 50% EPSS · CVSS 9.8 Critical · fixed in 3.0.6 : patch FlowiseAI Flowise as a priority.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 50.5% chance of exploitation in 30 days – higher than 98% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.0.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
t = 0 is the CVE’s publication on cve.org
Disclosed: evidence found.
CVE published 12 Sep 2025
Detectable: evidence found.
Weaponised: evidence found.
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
Timeline
CVE ID reserved
by GitHub_M
, 11 days before disclosure
CVE published
on cve.org
, t = 0
In Threat Radar
record ingested
, 5 minutes after disclosure
First Exploit-DB entry (opens in a new tab)
Flowise < 3.0.5 - Missing Authentication for Critical Function
, 243 days after disclosure
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| FlowiseAI Flowise | Affected
| Fixed in– |
AI-suggested
A fix is available in Flowise version 3.0.6 that secures the password reset endpoints by removing token exposure in API responses and enforcing secure token delivery via email. Users and administrators should upgrade to version 3.0.6 or later. Additionally, ensure the forgot-password endpoint returns generic success messages to prevent user enumeration, validate reset tokens as single-use with short expiry tied to request origin, and consider multi-factor verification for sensitive accounts. Apply these fixes to both cloud and self-hosted deployments.
Description
CVE-2025-58434 is a critical vulnerability in Flowise versions 3.0.5 and earlier where the forgot-password endpoint returns sensitive password reset tokens without requiring authentication. This flaw allows attackers to generate valid reset tokens for arbitrary users and reset their passwords, resulting in complete account takeover. The vulnerability affects both cloud and self-hosted deployments exposing the same API. Version 3.0.6 includes fixes that secure the password reset process by removing token exposure and enforcing proper validation and delivery methods.