Skip to main content
VulnerabilityPublished Updated

CVE-2025-58994: Greenify (WordPress plugin) · Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File

Affects Greenify (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 8.1 High : upgrade to 2.2 soon.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.2
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade designervily/greenify to 2.2.

Affected software

ProductAffectedFixed in
Packagistdesignervily/greenifypkg:composer/designervily/greenifyOther threatsAffected
  • <2.2
Fixed in
  • 2.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

No official patches or fixes are currently documented. Users should monitor for vendor updates and apply any official fixes once available. Until then, restricting access to vulnerable endpoints and applying web application firewall rules to detect and block suspicious include/require requests may help mitigate risk.

Description

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in designervily Greenify greenify allows PHP Local File Inclusion.This issue affects Greenify: from n/a through <= 2.2.

References

Community reviews

Loading reviews…