CVE-2025-59158: coollabsio coolify · Improper Encoding or Escaping of Output
Affects coollabsio coolifySource CVE Database V5
Not known to be exploited · CVSS 9.4 Critical : upgrade to 4.0.0-beta.420.7 as a priority.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.0.0-beta.420.7
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:HExploitation evidence
Disclosed: evidence found.
CVE published 5 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade coollabsio coolify to 4.0.0-beta.420.7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| coollabsiocoolify | Affected
| Fixed in
|
GitHubcoollabsio/coolifypkg:github/coollabsio/coolifyOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should immediately upgrade all Coolify instances to version 4.0.0-beta.420.7 or later to apply the official patch that fixes the improper output encoding. Until the upgrade can be performed, organizations should restrict project creation permissions to trusted users only, minimizing the risk of malicious project names being introduced. Implement strict input validation and output encoding at the application layer to prevent injection of executable scripts. Administrators should be trained to recognize suspicious project names and avoid interacting with untrusted projects. Employ Content Security Policy (CSP) headers to reduce the impact of XSS by restricting script execution sources. Regularly audit user roles and permissions to ensure least privilege principles are enforced. Monitor logs for unusual administrative actions or project creations. Consider isolating Coolify administrative interfaces behind VPNs or zero-trust network access to limit exposure. Finally, maintain an incident response plan to quickly address any suspected exploitation.
Description
Coolify is an open-source and self-hostable tool for managing servers, applications, and databases. Coolify versions prior to and including v4.0.0-beta.420.6 are vulnerable to a stored cross-site scripting (XSS) attack in the project creation workflow. An authenticated user with low privileges (e.g., member role) can create a project with a maliciously crafted name containing embedded JavaScript. When an administrator later attempts to delete the project or its associated resource, the payload automatically executes in the admin’s browser context. Version 4.0.0-beta.420.7 contains a patch for the issue.