CVE-2025-59302: Apache CloudStack · Code Injection
Affects Apache CloudStackSource CVE Database V5
Not known to be exploited · CVSS 4.7 Medium.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 27 Nov 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Mavenorg.apache.cloudstack/cloudstackpkg:maven/org.apache.cloudstack/cloudstackOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Organizations should immediately upgrade Apache CloudStack to versions 4.20.2 or 4.22.0, which include the fix for this vulnerability. Until upgrades can be applied, administrators should disable JavaScript expression interpretation in the affected APIs by setting the global configuration flag js.interpretation.enabled to false. Restrict administrative API access strictly to trusted personnel and secure management interfaces using network segmentation, VPNs, or zero-trust principles. Implement strong authentication mechanisms for admin accounts, including multi-factor authentication, to reduce the risk of credential compromise. Regularly audit API usage logs for suspicious activities or anomalous commands that could indicate attempted exploitation. Consider deploying runtime application self-protection (RASP) or web application firewalls (WAF) with custom rules to detect and block suspicious JavaScript payloads targeting these APIs. Conduct security awareness training for administrators to recognize and report unusual behaviors. Finally, maintain up-to-date backups and incident response plans to quickly recover from potential exploitation.
Description
In Apache CloudStack improper control of generation of code ('Code Injection') vulnerability is found in the following APIs which are accessible only to admins. * quotaTariffCreate * quotaTariffUpdate * createSecondaryStorageSelector * updateSecondaryStorageSelector * updateHost * updateStorage This issue affects Apache CloudStack: from 4.18.0 before 4.20.2, from 4.21.0 before 4.22.0. Users are recommended to upgrade to versions 4.20.2 or 4.22.0, which contain the fix. The fix introduces a new global configuration flag, js.interpretation.enabled, allowing administrators to control the interpretation of JavaScript expressions in these APIs, thereby mitigating the code injection risk.