CVE-2025-59790: Apache Kvrocks · Improper Privilege Management
Affects Apache KvrocksSource CVE Database V5
Not known to be exploited · CVSS 5.4 Medium · fixed in 2.14.0 : update Apache Kvrocks when convenient.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.14.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Nov 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software Foundation Apache Kvrocks | Affected
| Fixed in– |
AI-suggested
To mitigate CVE-2025-59790, European organizations should immediately upgrade Apache Kvrocks to version 2.14.0 or later, where the vulnerability is fixed. Beyond patching, organizations should conduct a thorough audit of privilege assignments and access controls within their Kvrocks deployments to ensure no excessive permissions exist. Implement network segmentation and restrict access to Kvrocks instances to trusted hosts and users only. Employ monitoring and alerting for unusual privilege escalations or access patterns. Where possible, enable and review detailed logging of access and administrative actions within Kvrocks to detect potential exploitation attempts. Additionally, integrate Kvrocks security posture into broader vulnerability management and incident response plans. For cloud deployments, leverage cloud provider security features such as identity and access management (IAM) policies to limit exposure. Finally, educate administrators and developers about secure privilege management practices to prevent similar issues in future deployments.
Description
Improper Privilege Management vulnerability in Apache Kvrocks. This issue affects Apache Kvrocks: from v2.9.0 through v2.13.0. Users are recommended to upgrade to version 2.14.0, which fixes the issue.