Skip to main content
CVE-2025-59845VulnerabilityPublished Updated

CVE-2025-59845: apollographql embeddable-explorer · Origin Validation Error

Affects apollographql embeddable-explorerSource CVE Database V5

0

Not known to be exploited · CVSS 8.2 High : upgrade to 3.7.3 or 2.7.2 soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 5% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.7.3, 2.7.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade apollographql embeddable-explorer to 3.7.3 or 2.7.2.

Affected software

ProductAffectedFixed in
apollographql embeddable-explorerAffected
  • <2.7.2
  • <3.7.3
Fixed in
  • 2.7.2
  • 3.7.3

AI-suggested

European organizations should immediately verify their use of Apollo GraphQL Embeddable Explorer or Sandbox components and upgrade to versions 3.7.3 and 2.7.2 or later respectively. Beyond patching, organizations should implement strict Content Security Policies (CSP) to restrict the domains allowed to embed or interact with these components, minimizing exposure to malicious origins. Additionally, reviewing and hardening GraphQL server-side authorization rules can limit the impact of unauthorized queries or mutations, ensuring that even if a CSRF attack occurs, sensitive operations require additional verification. Monitoring and logging GraphQL API usage for anomalous patterns can help detect exploitation attempts early. User awareness training to recognize phishing attempts that could trigger such attacks is also recommended. Finally, organizations should consider isolating embeddable components in sandboxed iframes with restrictive permissions to reduce the attack surface.

Description

Apollo Studio Embeddable Explorer & Embeddable Sandbox are website embeddable software solutions from Apollo GraphQL. Prior to Apollo Sandbox version 2.7.2 and Apollo Explorer version 3.7.3, a cross-site request forgery (CSRF) vulnerability was identified. The vulnerability arises from missing origin validation in the client-side code that handles window.postMessage events. A malicious website can send forged messages to the embedding page, causing the victim’s browser to execute arbitrary GraphQL queries or mutations against their GraphQL server while authenticated with the victim’s cookies. This issue has been patched in Apollo Sandbox version 2.7.2 and Apollo Explorer version 3.7.3.

References

Community reviews

Loading reviews…