Skip to main content
CVE-2025-59940VulnerabilityPublished

CVE-2025-59940: mondeja mkdocs-include-markdown-plugin · Improper Input Validation

Affects mondeja mkdocs-include-markdown-pluginSource CVE Database V5

0

Not known to be exploited · CVSS 6.5 Medium : upgrade to 7.1.8 when convenient.

Data as of 26 Oct 2026, 08:30 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 27% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.1.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade mondeja mkdocs-include-markdown-plugin to 7.1.8.

Affected software

ProductAffectedFixed in
mondeja mkdocs-include-markdown-pluginAffected
  • <7.1.8
Fixed in
  • 7.1.8

AI-suggested

The primary mitigation is to upgrade the mkdocs-include-markdown-plugin to version 7.1.8 or later, where the input validation flaw is fixed. Organizations should audit their documentation build pipelines to identify usage of this plugin and confirm version compliance. Additionally, review and sanitize all Markdown inputs that may be processed by the plugin to avoid unsafe substitution placeholders or unexpected content injection. Implement monitoring on documentation build processes to detect anomalies or failures that could indicate exploitation attempts. Integrate plugin version checks into continuous integration workflows to prevent deployment of vulnerable versions. Educate developers and technical writers about the risks of unvalidated inputs in documentation tooling. Finally, maintain awareness of updates from the plugin vendor and the Mkdocs community for any further security advisories.

Description

mkdocs-include-markdown-plugin is an Mkdocs Markdown includer plugin. In versions 7.1.7 and below, there is a vulnerability where unvalidated input can collide with substitution placeholders. This issue is fixed in version 7.1.8.

References

Community reviews

Loading reviews…