Skip to main content
VulnerabilityPublished

CVE-2025-59954: KnowageLabs Knowage-Server · Code Injection

Affects KnowageLabs Knowage-ServerSource CVE Database V5

0

Public exploit available · CVSS 9.3 Critical : upgrade to 8.1.27 as a priority.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.1.27
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade KnowageLabs Knowage-Server to 8.1.27.

Affected software

ProductAffectedFixed in
KnowageLabs Knowage-ServerAffected
  • <8.1.27
Fixed in
  • 8.1.27

AI-suggested

To mitigate CVE-2025-59954, organizations should immediately upgrade Knowage-Server to version 8.1.27 or later, where the vulnerability is fixed. If immediate upgrade is not feasible, restrict network access to the Knowage-Server instance using firewalls or network segmentation to limit exposure to trusted users only. Implement strict input validation and sanitization on any user-supplied data interacting with the MetaService or related components. Monitor logs and network traffic for unusual activity indicative of exploitation attempts, such as unexpected process executions or anomalous API calls. Employ application-layer firewalls or runtime application self-protection (RASP) tools to detect and block code injection attempts. Conduct thorough security audits and penetration tests focusing on the Knowage environment. Educate development and operations teams on secure coding practices to prevent similar issues. Finally, maintain an incident response plan tailored to potential exploitation scenarios involving BI platforms.

Description

Knowage is an open source analytics and business intelligence suite. Versions 8.1.26 and below are vulnerable to Remote Code Exection through using an unsafe org.apache.commons.jxpath.JXPathContext in MetaService.java service. This issue is fixed in version 8.1.27.

References

Community reviews

Loading reviews…