Skip to main content
CVE-2025-5998VulnerabilityPublished

CVE-2025-5998: PPWP (WordPress plugin) · Improper Handling of Insufficient Permissions or Privileges

Affects PPWP (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 6.5 Medium · fixed in 1.9.11 : update PPWP (WordPress plugin) when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.9.11
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Affected software

ProductAffectedFixed in
PPWP – Password Protect PagesAffected
  • =0
Fixed in–

AI-suggested

European organizations should immediately assess whether they use the PPWP – Password Protect Pages plugin and identify the plugin version. If running a vulnerable version prior to 1.9.11, they should upgrade to the latest patched version as soon as it becomes available. If you cannot patch yet, organizations should consider the following mitigations: 1) Restrict user registrations to trusted individuals only, minimizing the number of subscriber-level accounts. 2) Implement strong account monitoring and anomaly detection to identify suspicious subscriber account activity. 3) Disable or restrict REST API access for subscriber roles using custom code snippets or security plugins that control REST API permissions. 4) Review and limit the content protected by the plugin, avoiding storing highly sensitive data behind this mechanism until patched. 5) Employ Web Application Firewalls (WAFs) with rules to detect and block suspicious REST API requests that attempt to access protected content. 6) Educate site administrators and content managers about the vulnerability and the importance of timely updates. 7) Conduct regular audits of user roles and permissions to ensure least privilege principles are enforced. These targeted mitigations go beyond generic advice by focusing on controlling REST API access and subscriber role management, which are key to limiting exploitation of this specific vulnerability.

Description

The PPWP – Password Protect Pages WordPress plugin before version 1.9.11 allows to put the site content behind a password authorization, however users with subscriber or greater roles can view content via the REST API.

References

Community reviews

Loading reviews…