CVE-2025-6140: spdlog · Resource Consumption
Affects spdlogSource CVE Database V5
Not known to be exploited · CVSS 4.8 Medium.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 16 Jun 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubgabime/spdlogpkg:github/gabime/spdlogOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
1. Immediate upgrade of spdlog to version 1.15.2 or later in all affected applications and systems to apply the official patch addressing the vulnerability. 2. Conduct an inventory of all software products and internal applications that embed spdlog to identify vulnerable versions. 3. Implement strict local access controls and monitoring to limit the ability of unprivileged users to execute code or trigger logging functions that could exploit this vulnerability. 4. Employ resource usage monitoring and alerting on critical systems to detect unusual spikes in CPU or memory consumption that may indicate exploitation attempts. 5. For environments where immediate upgrade is not feasible, consider applying runtime mitigations such as sandboxing or limiting logging verbosity to reduce the attack surface. 6. Integrate this vulnerability into internal vulnerability management and patching workflows to ensure timely remediation. 7. Educate developers and system administrators about the risks associated with local resource exhaustion vulnerabilities and encourage secure coding and deployment practices around logging libraries.
Description
A vulnerability, which was classified as problematic, was found in spdlog up to 1.15.1. This affects the function scoped_padder in the library include/spdlog/pattern_formatter-inl.h. The manipulation leads to resource consumption. It is possible to launch the attack on the local host. The exploit has been disclosed to the public and may be used. Upgrading to version 1.15.2 is able to address this issue. The identifier of the patch is 10320184df1eb4638e253a34b1eb44ce78954094. It is recommended to upgrade the affected component.
References
- vuldb.com (opens in a new tab)
- vuldb.com (opens in a new tab)
- vuldb.com (opens in a new tab)
- github.com/gabime/spdlog/issues/3360 (opens in a new tab)
- github.com/gabime/spdlog/issues/3360 (opens in a new tab)
- github.com/gabime/spdlog/commit/10320184df1eb4638e253a34b1eb44ce78954094 (opens in a new tab)
- github.com/gabime/spdlog/releases/tag/v1.15.2 (opens in a new tab)