Skip to main content
CVE-2025-61674VulnerabilityPublished Updated

CVE-2025-61674: octobercms october · Cross-site Scripting

Affects octobercms octoberSource CVE Database V5

0

Not known to be exploited · CVSS 6.1 Medium : upgrade to 4.0.12 or 3.7.13 when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.0.12, 3.7.13
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade october to 4.0.12 or 3.7.13; octobercms/october to 3.7.13.

Affected software

ProductAffectedFixed in
octobercmsoctoberAffected
  • >=4.0.0 <4.0.12
  • <3.7.13
Fixed in
  • 4.0.12
  • 3.7.13
GitHuboctobercms/octoberpkg:github/octobercms/octoberOther threatsAffected
  • <3.7.13
Fixed in
  • 3.7.13

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations using October CMS should immediately verify their version and upgrade to 3.7.13 or 4.0.12 or later where the vulnerability is patched. Beyond patching, organizations should audit user permissions to ensure only trusted personnel have Global Editor Settings access, minimizing the risk of insider exploitation. Implement strict input validation and content security policies (CSP) on backend interfaces to reduce the impact of potential XSS attacks. Regularly monitor backend logs for unusual activity or script injections. Employ multi-factor authentication (MFA) for backend access to reduce the risk of compromised credentials being used to exploit this vulnerability. Conduct security awareness training for administrators and editors to recognize suspicious behavior or phishing attempts that could lead to credential compromise. Finally, consider isolating backend CMS management interfaces from public networks or restricting access via VPN or IP whitelisting to reduce exposure.

Description

October is a Content Management System (CMS) and web platform. Prior to versions 3.7.13 and 4.0.12, a cross-site scripting (XSS) vulnerability was identified in October CMS backend configuration forms. A user with the Global Editor Settings permission could inject malicious HTML/JS into the stylesheet input at Markup Styles. A specially crafted input could break out of the intended <style> context, allowing arbitrary script execution across backend pages for all users. This issue has been patched in versions 3.7.13 and 4.0.12.

References

Community reviews

Loading reviews…