Skip to main content
CVE-2025-61922VulnerabilityPublished

CVE-2025-61922: PrestaShopCorp ps_checkout · Improper Authentication

Affects PrestaShopCorp ps_checkoutSource CVE Database V5

0

Not known to be exploited · CVSS 9.1 Critical : upgrade to 5.0.5 or 4.4.1 as a priority.

Data as of 26 Oct 2026, 08:30 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.0.5, 4.4.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade prestashopcorp/ps_checkout to 5.0.5 or 4.4.1.

Affected software

ProductAffectedFixed in
GitHubprestashopcorp/ps_checkoutpkg:github/prestashopcorp/ps_checkoutOther threatsAffected
  • >=1.3.0 <4.4.1
  • >=1.3.0 <5.0.5
Fixed in
  • 4.4.1
  • 5.0.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The primary mitigation is to upgrade the ps_checkout module to version 4.4.1 or later, or 5.0.5 or later, where the vulnerability is patched. Organizations should audit their PrestaShop installations to identify affected versions and prioritize patching. Since no workarounds exist, temporary measures such as disabling the Express Checkout feature could reduce exposure but may impact user experience. Implementing additional monitoring for unusual login activity or account behavior can help detect exploitation attempts. Enforcing multi-factor authentication (MFA) at the application or payment gateway level may provide an additional security layer, although it may not fully prevent silent logins caused by this vulnerability. Regularly reviewing access logs and integrating threat intelligence feeds for emerging exploit indicators is recommended. Finally, organizations should notify customers about potential risks and encourage vigilance against phishing or suspicious activity.

Description

PrestaShop Checkout is the PrestaShop official payment module in partnership with PayPal. Starting in version 1.3.0 and prior to versions 4.4.1 and 5.0.5, missing validation on the Express Checkout feature allows silent login, enabling account takeover via email. The vulnerability is fixed in versions 4.4.1 and 5.0.5. No known workarounds exist.

References

Community reviews

Loading reviews…