CVE-2025-61994: GROWI · Cross-site scripting (XSS)
Affects GROWISource CVE Database V5
Not known to be exploited · CVSS 5.4 Medium : upgrade to 7.2.10 when convenient.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.2.10
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Nov 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade GROWI to 7.2.10.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| GROWI, Inc. GROWI | Affected
| Fixed in
|
AI-suggested
1. Upgrade all GROWI instances to version 7.2.10 or later immediately to apply the official patch addressing this XSS vulnerability. 2. Implement strict user access controls and limit page creation or editing privileges to trusted users only, reducing the risk of malicious content injection. 3. Employ Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts in browsers accessing GROWI pages. 4. Conduct regular security audits and code reviews of user-generated content handling to detect and remediate similar injection flaws. 5. Educate users about the risks of clicking on untrusted links or pages within the internal documentation platform. 6. Monitor logs for unusual page creation or modification activities that could indicate exploitation attempts. 7. Consider deploying web application firewalls (WAF) with rules targeting XSS attack patterns specific to GROWI. 8. If upgrading is delayed, temporarily disable or restrict page creation/editing features for non-administrative users as a stopgap measure.
Description
Cross-site scripting vulnerability exists in GROWI prior to v7.2.10. If a malicious user creates a page containing crafted contents, an arbitrary script may be executed on the web browser of a victim user who accesses the page.