Skip to main content
VulnerabilityPublished

CVE-2025-62602: eProsima Fast-DDS · Heap-based Buffer Overflow

Affects eProsima Fast-DDSSource CVE Database V5

0

Not known to be exploited · CVSS 1.7 Low · fixed in 3.4.1 : update eProsima Fast-DDS when convenient.

Data as of 26 Oct 2026, 12:55 UTC

CVSS 4.0 base score
1.7Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.4.1, 3.3.1, 2.6.11
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:U

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade eProsima Fast-DDS to 3.4.1, 3.3.1 or 2.6.11.

Affected software

ProductAffectedFixed in
eProsimaFast-DDSAffected
  • >=3.4.0 <3.4.1
Fixed in
  • 3.4.1
eProsimaFast-DDSAffected
  • >=3.0.0 <3.3.1
Fixed in
  • 3.3.1
eProsimaFast-DDSAffected
  • <2.6.11
Fixed in
  • 2.6.11
GitHubeprosima/Fast-DDSpkg:github/eprosima/Fast-DDSOther threatsAffected
  • =0
  • =3.0.0
  • =3.4.0
Fixed in–
GitHubFast-DDSpkg:github/Fast-DDSOther threatsAffected
  • >=3.4.0 <3.4.1
  • >=3.0.0 <3.3.1
  • <2.6.11
Fixed in
  • 3.4.1
  • 3.3.1
  • 2.6.11

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should prioritize upgrading eProsima Fast-DDS to versions 3.4.1, 3.3.1, or 2.6.11 or later, where the vulnerability is patched. Network-level filtering can be implemented to restrict or monitor SPDP packets, especially those containing PID_IDENTITY_TOKEN or PID_PERMISSIONS_TOKEN fields, to detect anomalous or malformed messages. Deploying intrusion detection systems (IDS) with custom signatures for malformed DDS packets may help identify exploitation attempts. Additionally, organizations should enforce strict network segmentation to isolate DDS traffic and reduce exposure to untrusted networks. Regularly auditing and monitoring Fast-DDS logs for unexpected process terminations can provide early warning of exploitation attempts. Finally, integrating Fast-DDS updates into the organization's patch management lifecycle will ensure timely remediation of future vulnerabilities.

Description

Fast DDS is a C++ implementation of the DDS (Data Distribution Service) standard of the OMG (Object Management Group ). Prior to versions 3.4.1, 3.3.1, and 2.6.11, when the security mode is enabled, modifying the DATA Submessage within an SPDP packet sent by a publisher causes a heap buffer overflow, resulting in remote termination of Fast-DDS. If the fields of `PID_IDENTITY_TOKEN` or `PID_PERMISSIONS_TOKEN` in the DATA Submessage are tampered with — specially `readOctetVector` reads an unchecked `vecsize` that is propagated unchanged into `readData` as the `length` parameter — the attacker-contro lled `vecsize` can trigger a 32-bit integer overflow during the `length` calculation. That overflow can cause large alloca tion attempt that quickly leads to OOM, enabling a remotely-triggerable denial-of-service and remote process termination. Versions 3.4.1, 3.3.1, and 2.6.11 patch the issue.

References

Community reviews

Loading reviews…