Skip to main content
VulnerabilityPublished

CVE-2025-62725: docker compose · Path Traversal

Affects docker composeSource CVE Database V5

0
Compare

Not known to be exploited · 15% EPSS · CVSS 8.9 High : upgrade to 2.40.2 soon.

Data as of 7 Nov 2026, 23:24 UTC

CVSS 4.0 base score
8.9High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
15.7% chance of exploitation in 30 days – higher than 96% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.40.2
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.

What to do

Upgrade compose and docker/compose to 2.40.2.

Affected software

ProductAffectedFixed in
dockercomposeAffected
  • <2.40.2
Fixed in
  • 2.40.2
GitHubdocker/composepkg:github/docker/composeOther threatsAffected
  • <2.40.2
Fixed in
  • 2.40.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Docker Compose version 2.40.2. Users and administrators should upgrade to version 2.40.2 or later to remediate this vulnerability. There is no indication that any temporary workaround or mitigation is effective or recommended. Applying the official fix is the advised course of action.

Description

CVE-2025-62725 is a path traversal vulnerability in Docker Compose that allows an attacker to escape the local cache directory and overwrite arbitrary files on the host machine. This occurs because Docker Compose trusts path information embedded in remote OCI compose artifacts and improperly joins attacker-supplied values with local paths. The vulnerability affects multiple platforms and workflows that resolve remote OCI compose artifacts, including Docker Desktop, standalone Compose binaries on Linux, CI/CD runners, and cloud development environments. The issue is fixed in Docker Compose version 2.40.2.

References

Community reviews

Loading reviews…