CVE-2025-62728: Apache Hive · SQL Injection
Affects Apache HiveSource CVE Database V5
Not known to be exploited · CVSS 5.4 Medium · fixed in 4.2.0 : update Apache Hive when convenient.
Data as of 26 Oct 2026, 12:55 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.2.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 26 Nov 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Mavenorg.apache.hive/hivepkg:maven/org.apache.hive/hiveOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should prioritize upgrading Apache Hive to version 4.2.0 or later, where the vulnerability is patched. If immediate upgrade is not feasible, they must ensure the metastore.try.direct.sql property is set to false to disable the vulnerable code path. Access controls should be strictly enforced to limit HMS Thrift API access only to trusted and authorized applications, ideally restricting network access via firewall rules and network segmentation. Implement monitoring and logging of HMS API calls to detect anomalous or unauthorized requests. Conduct regular security audits of big data infrastructure to verify configuration compliance and access policies. Employ application-layer firewalls or API gateways where possible to add an additional layer of input validation and request filtering. Educate administrators and developers on secure configuration practices for Apache Hive and the risks of exposing internal APIs. Finally, integrate vulnerability management processes to promptly apply patches and configuration updates upon disclosure.
Description
SQL injection vulnerability in Hive Metastore Server (HMS) when processing delete column statistics requests via the Thrift APIs. The vulnerability is only exploitable by trusted/authorized users/applications that are allowed to call directly the Thrift APIs. In most real-world deployments, HMS is accessible to only a handful of applications (e.g., Hiveserver2) thus the vulnerability is not exploitable. Moreover, the vulnerable code cannot be reached when metastore.try.direct.sql property is set to false. This issue affects Apache Hive: from 4.1.0 before 4.2.0. Users are recommended to upgrade to version 4.2.0, which fixes the issue. Users who cannot upgrade directly are encouraged to set metastore.try.direct.sql property to false if the HMS Thrift APIs are exposed to general public.