Skip to main content
CVE-2025-62799VulnerabilityPublished

CVE-2025-62799: eProsima Fast-DDS · Heap-based Buffer Overflow

Affects eProsima Fast-DDSSource CVE Database V5

0

Not known to be exploited · CVSS 7.2 High · fixed in 3.4.1 : patch eProsima Fast-DDS soon.

Data as of 26 Oct 2026, 08:30 UTC

CVSS 4.0 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.4.1, 3.3.1, 2.6.11
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Fast-DDS to 3.4.1, 3.3.1 or 2.6.11; eprosima/Fast-DDS to 3.3.1 or 2.6.11.

Affected software

ProductAffectedFixed in
eProsimaFast-DDSAffected
  • >=3.4.0 <3.4.1
  • >=3.0.0 <3.3.1
  • <2.6.11
Fixed in
  • 3.4.1
  • 3.3.1
  • 2.6.11
GitHubeprosima/Fast-DDSpkg:github/eprosima/Fast-DDSOther threatsAffected
  • <2.6.11
  • >=3.0.0 <3.3.1
  • =3.4.0
Fixed in
  • 2.6.11
  • 3.3.1
GitHubFast-DDSpkg:github/Fast-DDSOther threatsAffected
  • >=3.4.0 <3.4.1
  • >=3.0.0 <3.3.1
  • <2.6.11
Fixed in
  • 3.4.1
  • 3.3.1
  • 2.6.11

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately identify all deployments of eProsima Fast-DDS and verify the versions in use. Systems running versions prior to 3.4.1, 3.3.1, or 2.6.11 must be upgraded to the patched versions without delay. Network segmentation and strict firewall rules should be applied to limit exposure of Fast-DDS services to untrusted networks. Employing intrusion detection systems (IDS) with signatures or anomaly detection for malformed RTPS DATA_FRAG packets can help detect exploitation attempts. Additionally, implementing runtime protections such as heap overflow mitigations (e.g., ASLR, DEP) and continuous monitoring for crashes or unusual behavior in Fast-DDS components is recommended. For environments where immediate patching is not feasible, consider disabling or restricting the use of the DATA_FRAG feature or isolating affected systems until updates can be applied. Vendor coordination for timely updates and security advisories should be maintained.

Description

Fast DDS is a C++ implementation of the DDS (Data Distribution Service) standard of the OMG (Object Management Group ). Prior to versions 3.4.1, 3.3.1, and 2.6.11, a heap buffer overflow exists in the Fast-DDS DATA_FRAG receive path. An un authenticated sender can transmit a single malformed RTPS DATA_FRAG packet where `fragmentSize` and `sampleSize` are craft ed to violate internal assumptions. Due to a 4-byte alignment step during fragment metadata initialization, the code write s past the end of the allocated payload buffer, causing immediate crash (DoS) and potentially enabling memory corruption ( RCE risk). Versions 3.4.1, 3.3.1, and 2.6.11 patch the issue.

References

Community reviews

Loading reviews…