Skip to main content
CVE-2025-6338VulnerabilityPublished Updated

CVE-2025-6338: Qt · Incomplete Cleanup

Affects QtSource CVE Database V5

0

Not known to be exploited · CVSS 9.2 Critical : upgrade to 6.9.2 or 6.8.4 as a priority.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.9.2, 6.8.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade org.qtproject/qt to 6.9.2 or 6.8.4.

Affected software

ProductAffectedFixed in
Mavenorg.qtproject/qtpkg:maven/org.qtproject/qtOther threatsAffected
  • >=5.15.0 <6.8.4
  • >=6.9.0 <6.9.2
Fixed in
  • 6.8.4
  • 6.9.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

No specific mitigation steps are detailed in the available data.

Description

There is an incomplete cleanup vulnerability in Qt Network's Schannel support on Windows which can lead to a Denial of Service over a long period. This issue affects Qt from 5.15.0 through 6.8.3, from 6.9.0 before 6.9.2.

References

Community reviews

Loading reviews…