Skip to main content
CVE-2025-64404VulnerabilityPublished Updated

CVE-2025-64404: Apache OpenOffice · Missing Authorization

Affects Apache OpenOfficeSource CVE Database V5

0

Not known to be exploited · CVSS 7.5 High : upgrade to 4.1.16 soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.2% chance of exploitation in 30 days – higher than 69% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.1.16
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade org.apache.openoffice/openoffice to 4.1.16.

Affected software

ProductAffectedFixed in
Mavenorg.apache.openoffice/openofficepkg:maven/org.apache.openoffice/openofficeOther threatsAffected
  • <4.1.16
Fixed in
  • 4.1.16

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately upgrade all Apache OpenOffice installations to version 4.1.16 or later to remediate this vulnerability. Until upgrades are complete, organizations should implement strict document handling policies, including disabling automatic loading of external content in OpenOffice settings if possible. Employ network-level controls to restrict outbound connections from workstations running Apache OpenOffice to untrusted external resources. Educate users to be cautious with documents from untrusted sources, especially those containing embedded images or external links. Use endpoint detection and response (EDR) tools to monitor for unusual file access or network activity triggered by document processing. Incorporate document sanitization or scanning solutions that can detect and block malicious embedded links. Maintain an inventory of systems running Apache OpenOffice to ensure comprehensive patch deployment. Finally, monitor vendor advisories and threat intelligence feeds for any emerging exploit activity related to this CVE.

Description

Apache OpenOffice documents can contain links to other files. A missing Authorization vulnerability in Apache OpenOffice allowed an attacker to craft a document that would cause external links to be loaded without prompt. In the affected versions of Apache OpenOffice, documents that used background fill images, or bullet images, linked to external files would load the contents of those files without prompting the user for permission to do so. This issue affects Apache OpenOffice: through 4.1.15. Users are recommended to upgrade to version 4.1.16, which fixes the issue.

References

Community reviews

Loading reviews…