CVE-2025-65012: getkirby kirby · Cross-site Scripting
Affects getkirby kirbySource CVE Database V5
Not known to be exploited · CVSS 5.1 Medium : upgrade to 5.1.4 when convenient.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.1.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 18 Nov 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade getkirby/kirby to 5.1.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubgetkirby/kirbypkg:github/getkirby/kirbyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should immediately upgrade all Kirby CMS installations to version 5.1.4 or later to remediate this vulnerability. Until patching is possible, restrict Panel access strictly to trusted users and enforce strong authentication mechanisms such as multi-factor authentication (MFA) to reduce the risk of compromised accounts. Implement rigorous input validation and sanitization on user-modifiable fields like page titles and usernames, if customization is possible beyond the core CMS. Monitor logs for unusual changes to page titles or usernames and audit the 'Changes' dialog access patterns for suspicious activity. Educate users with Panel access about the risks of interacting with untrusted content and encourage cautious behavior when reviewing changes. Consider deploying Content Security Policy (CSP) headers to limit the execution of injected scripts within the Panel interface. Finally, conduct regular security assessments and vulnerability scans on CMS installations to detect outdated versions or misconfigurations.
Description
Kirby is an open-source content management system. From versions 5.0.0 to 5.1.3, attackers could change the title of any page or the name of any user to a malicious string. Then they could modify any content field of the same model without saving, making the model a candidate for display in the "Changes" dialog. If another authenticated user subsequently opened the dialog in their Panel, the malicious code would be executed. This vulnerability affects all Kirby 5 sites that might have potential attackers in the group of authenticated Panel users or that allow external visitors to update page titles or usernames. The attack requires user interaction by another Panel user and cannot be automated. This issue has been patched in version 5.1.4.