Skip to main content
VulnerabilityPublished

CVE-2025-65034: lukevella rallly · Insecure Direct Object Reference

Affects lukevella ralllySource CVE Database V5

0

Not known to be exploited · CVSS 8.1 High : upgrade to 4.5.4 soon.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.5.4
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade lukevella/rallly to 4.5.4.

Affected software

ProductAffectedFixed in
GitHublukevella/ralllypkg:github/lukevella/ralllyOther threatsAffected
  • <4.5.4
Fixed in
  • 4.5.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately upgrade all Rallly instances to version 4.5.4 or later where the vulnerability is patched. In addition, organizations should audit user permissions and access controls related to poll management to ensure least privilege principles are enforced. Implement monitoring and alerting for unusual poll reopening activities, especially those initiated by users who do not own the polls. Consider network segmentation and access restrictions to limit authenticated user capabilities where possible. For self-hosted deployments, verify that all dependencies and integrations are compatible with the patched version to avoid operational disruptions. Conduct security awareness training to reduce risks from compromised credentials. Finally, maintain an incident response plan to quickly address any exploitation attempts or operational impacts stemming from this vulnerability.

Description

Rallly is an open-source scheduling and collaboration tool. Prior to version 4.5.4, an improper authorization vulnerability allows any authenticated user to reopen finalized polls belonging to other users by manipulating the pollId parameter. This can disrupt events managed by other users and compromise both availability and integrity of poll data. This issue has been patched in version 4.5.4.

References

Community reviews

Loading reviews…