CVE-2025-65199: Windscribe for Linux Desktop App · OS Command Injection
Affects Windscribe for Linux Desktop AppSource CVE Database V5
Not known to be exploited · CVSS 7.8 High · fixed in 2.18.3 : patch Windscribe for Linux Desktop App soon.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 1.2% chance of exploitation in 30 days – higher than 69% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.18.3
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 10 Dec 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubwindscribe/Desktop-Apppkg:github/windscribe/Desktop-AppOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
- Upgrade all Windscribe for Linux Desktop App installations to version 2.18.3-alpha or later, or 2.18.8 or later, where the vulnerability is patched.
- Audit and restrict membership of the 'windscribe' group to only trusted and necessary users to minimize the attack surface.
- Implement strict local access controls and monitoring to detect unauthorized attempts to exploit the vulnerability.
- Employ application whitelisting and endpoint detection and response (EDR) solutions to identify anomalous command execution patterns.
- Educate system administrators and users about the risks of privilege escalation vulnerabilities and the importance of applying security updates promptly.
- Consider isolating VPN client usage to dedicated systems or containers to limit potential lateral movement in case of compromise.
Description
A command injection vulnerability exists in Windscribe for Linux Desktop App that allows a local user who is a member of the windscribe group to execute arbitrary commands as root via the 'adapterName' parameter of the 'changeMTU' function. Fixed in Windscribe v2.18.3-alpha and v2.18.8.
References
- github.com/Windscribe/Desktop-App (opens in a new tab)
- github.com/Windscribe/Desktop-App/compare/v2.18.2...v2.18.3?diff=unified&w (opens in a new tab)
- github.com/Windscribe/Desktop-App/compare/v2.18.2...v2.18.3?diff=unified&w (opens in a new tab)
- hackingbydoing.wixsite.com/hackingbydoing/post/windscribe-vpn-local-privilege-escalation (opens in a new tab)
- cve.org/CVERecord?id=CVE-2025-65199 (opens in a new tab)
- raw.githubusercontent.com/cisagov/CSAF/develop/csaf_files/IT/white/2025/va-25-343-01.json (opens in a new tab)