Skip to main content
VulnerabilityPublished Updated

CVE-2025-66024: xwiki-contrib application-blog-ui · Cross-site Scripting

Affects xwiki-contrib application-blog-uiSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.6 High : upgrade to 9.15.7 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.15.7
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade application-blog-ui and xwiki-contrib/application-blog-ui to 9.15.7.

Affected software

ProductAffectedFixed in
xwiki-contribapplication-blog-uiAffected
  • >=9.15 <9.15.7
Fixed in
  • 9.15.7
GitHubxwiki-contrib/application-blog-uipkg:github/xwiki-contrib/application-blog-uiOther threatsAffected
  • <9.15.7
Fixed in
  • 9.15.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

An official patch is available in application-blog-ui version 9.15.7 that fixes the vulnerability by adding proper escaping to the blog post title. Users should upgrade to version 9.15.7 or later to remediate this issue. No workarounds are currently known.

Description

The XWiki blog application allows users of the XWiki platform to create and manage blog posts. Versions starting with 9.15 and prior to 9.15.7 are vulnerable to Stored Cross-Site Scripting (XSS) via the Blog Post Title. The vulnerability arises because the post title is injected directly into the HTML <title> tag without proper escaping. An attacker with permissions to create or edit blog posts can inject malicious JavaScript into the title field. This script will execute in the browser of any user (including administrators) who views the blog post. This leads to potential session hijacking or privilege escalation. The vulnerability has been patched in the blog application version 9.15.7 by adding missing escaping. No known workarounds are available.

References

Community reviews

Loading reviews…