Skip to main content
CVE-2025-66311VulnerabilityPublished

CVE-2025-66311: getgrav grav · Cross-site Scripting

Affects getgrav gravSource CVE Database V5

0

Not known to be exploited · CVSS 6.2 Medium · fixed in 1.11.0 : update getgrav grav when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 4.0 base score
6.2Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.11.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:L/VI:L/VA:N/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Affected software

ProductAffectedFixed in
GitHubgetgrav/gravpkg:github/getgrav/gravOther threatsAffected
  • =1.11.0-beta.1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

1. Immediate upgrade of the Grav admin plugin to version 1.11.0-beta.1 or later, where the vulnerability is fixed. 2. Implement strict access controls and multi-factor authentication (MFA) for all administrative accounts to reduce the risk of credential compromise. 3. Conduct regular audits of administrative user activity and page metadata to detect suspicious or unauthorized changes. 4. Employ Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts within the admin interface. 5. Sanitize and validate all user inputs at the application level, especially metadata and taxonomy fields, to prevent injection of malicious content. 6. Limit the number of users with administrative privileges and enforce the principle of least privilege. 7. Monitor logs for unusual access patterns or repeated attempts to inject scripts. 8. Educate administrators about the risks of stored XSS and safe content management practices. 9. If upgrading immediately is not feasible, consider temporarily restricting access to the admin interface to trusted IP addresses or VPNs.

Description

This admin plugin for Grav is an HTML user interface that provides a convenient way to configure Grav and easily create and modify pages. Prior to 1.11.0-beta.1, a Stored Cross-Site Scripting (XSS) vulnerability was identified in the /admin/pages/[page] endpoint of the Grav application. This vulnerability allows attackers to inject malicious scripts into the data[header][metadata], data[header][taxonomy][category], and data[header][taxonomy][tag] parameters. These scripts are stored in the page frontmatter and executed automatically whenever the affected page is accessed or rendered in the administrative interface. This vulnerability is fixed in 1.11.0-beta.1.

References

Community reviews

Loading reviews…