CVE-2025-66454: ArcadeAI arcade-mcp · Use of Hard-coded Cryptographic Key
Affects ArcadeAI arcade-mcpSource CVE Database V5
Not known to be exploited · CVSS 6.5 Medium : upgrade to 1.5.4 when convenient.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.5.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 2 Dec 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade arcadeai/arcade-mcp to 1.5.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubarcadeai/arcade-mcppkg:github/arcadeai/arcade-mcpOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should immediately verify if they are running arcade-mcp versions earlier than 1.5.4. The primary mitigation is to upgrade all affected instances to version 1.5.4 or later, where the hardcoded secret is removed or properly secured. If upgrading is not immediately possible, organizations should restrict network access to arcade-mcp servers by implementing strict firewall rules, allowing only trusted internal IP addresses to connect. Additionally, monitoring and logging of all authentication attempts and tool invocations should be enhanced to detect suspicious activity indicative of JWT forgery or unauthorized access. Organizations should also consider implementing additional layers of authentication or API gateway protections in front of arcade-mcp endpoints. Regular security audits and code reviews should be conducted to identify any other hardcoded secrets or similar cryptographic weaknesses. Finally, educating developers and administrators about the risks of hardcoded credentials and enforcing secure key management practices will help prevent similar vulnerabilities.
Description
CVE-2025-66454 is a medium severity vulnerability in ArcadeAI's arcade-mcp HTTP server versions prior to 1.5.4. The server uses a hardcoded default worker secret key "dev" that is never validated or overridden during startup. This allows unauthenticated attackers who know the default key to forge valid JWT tokens, bypassing FastAPI authentication entirely. Exploitation grants remote access to all worker endpoints, including tool enumeration and invocation, without any credentials. The vulnerability does not require user interaction or privileges and is exploitable over the network. It is fixed in version 1.5.4.