CVE-2025-66457: elysiajs elysia · Code Injection
Affects elysiajs elysiaSource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 1.4.18 soon.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.8% chance of exploitation in 30 days – higher than 56% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.4.18
CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 9 Dec 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade elysiajs/elysia to 1.4.18.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
npmelysiajs/elysiapkg:npm/elysiajs/elysiaOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should immediately upgrade Elysia framework instances to version 1.4.18 or later to remediate this vulnerability. Additionally, they should enforce strict access controls and auditing on configuration management systems to prevent unauthorized modifications to cookie configurations. Implement environment hardening by isolating configuration provisioning processes and using immutable infrastructure principles where possible. Conduct thorough code reviews and automated scanning to detect unsafe code injection patterns. Employ runtime application self-protection (RASP) and web application firewalls (WAF) configured to detect anomalous behavior related to cookie handling. Regularly monitor logs for suspicious changes to configuration files or unexpected code execution patterns. Finally, integrate vulnerability management processes to track dependencies and ensure timely updates of third-party frameworks like Elysia.
Description
Elysia is a Typescript framework for request validation, type inference, OpenAPI documentation and client-server communication. Versions 1.4.17 and below are subject to arbitrary code execution from cookie config. When dynamic cookies are enabled (e.g.there an existing cookie schema), the cookie config is injected into the compiled route without first being sanitised. Availability of this exploit is generally low, but when combined with GHSA-hxj9-33pp-j2cc, it allows for a full RCE chain. An attack requires write access to either the Elysia app's source code (in which case the vulnerability is meaningless) or write access to the cookie config (perhaps where it is assumed to be provisioned by the environment). This issue is fixed in version 1.4.18.
References
- github.com/elysiajs/elysia/security/advisories/GHSA-8vch-m3f4-q8jf (opens in a new tab)
- github.com/elysiajs/elysia/security/advisories/GHSA-hxj9-33pp-j2cc (opens in a new tab)
- github.com/elysiajs/elysia/pull/1564 (opens in a new tab)
- github.com/elysiajs/elysia/commit/26935bf76ebc43b4a43d48b173fc853de43bb51e (opens in a new tab)
- github.com/elysiajs/elysia/commit/3af978663e437dccc6c1a2a3aff4b74e1574849e (opens in a new tab)
- github.com/sportshead/elysia-poc (opens in a new tab)