CVE-2025-66469: zauberzeug nicegui · Cross-site Scripting
Affects zauberzeug niceguiSource CVE Database V5
Not known to be exploited · CVSS 6.1 Medium : upgrade to 3.4.0 when convenient.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.4.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Dec 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade zauberzeug nicegui to 3.4.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
PyPIniceguipkg:pypi/niceguiOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
European organizations should immediately upgrade all NiceGUI deployments to version 3.4.0 or later to eliminate the vulnerability. Where immediate upgrading is not feasible, implement strict input validation and sanitization on all user-supplied data passed to ui.add_css, ui.add_scss, and ui.add_sass functions, ensuring that injected content cannot break out of style or script contexts. Employ Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts and reduce the impact of potential XSS attacks. Conduct thorough code reviews and penetration testing focused on client-side injection vectors in applications using NiceGUI. Educate users and administrators about the risks of clicking untrusted links and the importance of applying security updates promptly. Monitor web application logs for suspicious requests that may indicate attempted exploitation. Additionally, consider implementing web application firewalls (WAFs) with rules designed to detect and block reflected XSS payloads targeting NiceGUI endpoints.
Description
NiceGUI is a Python-based UI framework. Versions 3.3.1 and below are vulnerable to Reflected XSS through its ui.add_css, ui.add_scss, and ui.add_sass functions. The functions lack proper sanitization or encoding for the JavaScript context they generate. An attacker can break out of the intended <style> or <script> tags by injecting closing tags (e.g., </style> or </script>), allowing for the execution of arbitrary JavaScript. This issue is fixed in version 3.4.0.