Skip to main content
CVE-2025-6674VulnerabilityPublished

CVE-2025-6674: Drupal CKEditor5 Youtube · Cross-site Scripting

Affects Drupal CKEditor5 YoutubeSource CVE Database V5

0

Not known to be exploited · CVSS 6.1 Medium : upgrade to 1.0.3 when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.0.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade drupal/ckeditor5_youtube to 1.0.3.

Affected software

ProductAffectedFixed in
Packagistdrupal/ckeditor5_youtubepkg:composer/drupal/ckeditor5_youtubeOther threatsAffected
  • =0.0.0 <1.0.3
Fixed in
  • 1.0.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Organizations should immediately audit their Drupal installations to identify the presence and version of the CKEditor5 Youtube plugin. Upgrading to version 1.0.3 or later, once available, is critical to remediate the vulnerability. In the interim, disabling or removing the CKEditor5 Youtube plugin can mitigate risk. Implementing Content Security Policy (CSP) headers can reduce the impact of XSS by restricting script execution sources. Additionally, applying strict input validation and output encoding on all user-supplied content, especially embedded media URLs, is essential. Web Application Firewalls (WAFs) with rules targeting XSS payloads can provide temporary protection. Regular security scanning and monitoring for anomalous activities related to script injection attempts should be established. Finally, educating developers and content managers on secure content embedding practices will help prevent similar vulnerabilities.

Description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal CKEditor5 Youtube allows Cross-Site Scripting (XSS).This issue affects CKEditor5 Youtube: from 0.0.0 before 1.0.3.

References

Community reviews

Loading reviews…