Skip to main content
CVE-2025-6709VulnerabilityPublished

CVE-2025-6709: MongoDB Server · Improper Input Validation

Affects MongoDB ServerSource CVE Database V5

0

Not known to be exploited · CVSS 7.5 High · fixed in 8.0.5 : patch MongoDB Server soon.

Data as of 26 Oct 2026, 08:30 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.0.5, 7.0.17, 6.0.21
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade MongoDB Server to 8.0.5, 7.0.17 or 6.0.21.

Affected software

ProductAffectedFixed in
MongoDB Inc MongoDB ServerAffected
  • =7.0
  • =8.0
  • =6.0
  • =6.0 <6.0.21
  • =7.0 <7.0.17
  • =8.0 <8.0.5
Fixed in
  • 6.0.21
  • 7.0.17
  • 8.0.5

AI-suggested

European organizations should prioritize upgrading MongoDB Server to the fixed versions: 7.0.17 or later for the 7.0 branch, 8.0.5 or later for the 8.0 branch, and 6.0.21 or later for the 6.0 branch. If immediate upgrade is not feasible, organizations should implement network-level controls to restrict access to MongoDB instances, especially from untrusted networks, to reduce exposure. Enforce strict authentication and authorization policies, particularly for version 6.0 deployments, to limit potential attackers. Monitoring and alerting on unusual JSON payloads or OIDC authentication attempts can help detect exploitation attempts. Additionally, organizations should review their OIDC configurations and input validation mechanisms to ensure robust sanitization of date and other JSON fields. Conducting penetration testing focused on authentication flows and input validation can identify residual weaknesses. Finally, maintain up-to-date backups and incident response plans to minimize operational impact in case of successful DoS attacks.

Description

The MongoDB Server is susceptible to a denial of service vulnerability due to improper handling of specific date values in JSON input when using OIDC authentication. This can be reproduced using the mongo shell to send a malicious JSON payload leading to an invariant failure and server crash. This issue affects MongoDB Server v7.0 versions prior to 7.0.17 and MongoDB Server v8.0 versions prior to 8.0.5. The same issue affects MongoDB Server v6.0 versions prior to 6.0.21, but an attacker can only induce denial of service after authenticating.

References

Community reviews

Loading reviews…