Skip to main content
VulnerabilityPublished

CVE-2025-67504: WBCE_CMS · Insufficient Entropy

Affects WBCE_CMSSource CVE Database V5

0

Not known to be exploited · CVSS 9.1 Critical : upgrade to 1.6.5 as a priority.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.6.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade wbce/WBCE_CMS to 1.6.5.

Affected software

ProductAffectedFixed in
GitHubwbce/WBCE_CMSpkg:github/wbce/WBCE_CMSOther threatsAffected
  • <1.6.5
Fixed in
  • 1.6.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Immediate upgrade to WBCE CMS version 1.6.5 or later is the primary mitigation step, as this version replaces the insecure rand() function with a cryptographically secure random number generator. Organizations should audit their current WBCE CMS installations to identify vulnerable versions and prioritize patching. In parallel, review and enforce strong password policies and consider implementing multi-factor authentication (MFA) to reduce the risk of account compromise. Monitor logs for unusual login attempts or brute-force activity targeting password reset functions. If upgrading is temporarily not feasible, consider disabling password auto-generation features or replacing them with secure custom implementations using PHP's random_int() or openssl_random_pseudo_bytes(). Conduct security awareness training for administrators to recognize potential exploitation signs. Finally, ensure regular backups and incident response plans are in place to mitigate potential damage from exploitation.

Description

WBCE CMS is a content management system. Versions 1.6.4 and below use function GenerateRandomPassword() to create passwords using PHP's rand(). rand() is not cryptographically secure, which allows password sequences to be predicted or brute-forced. This can lead to user account compromise or privilege escalation if these passwords are used for new accounts or password resets. The vulnerability is fixed in version 1.6.5.

References

Community reviews

Loading reviews…