Skip to main content
CVE-2025-67734VulnerabilityPublished

CVE-2025-67734: frappe lms · Cross-site Scripting

Affects frappe lmsSource CVE Database V5

0

Not known to be exploited · CVSS 5.1 Medium : upgrade to 2.42.0 when convenient.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.42.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade frappe/lms to 2.42.0.

Affected software

ProductAffectedFixed in
GitHubfrappe/lmspkg:github/frappe/lmsOther threatsAffected
  • <2.42.0
Fixed in
  • 2.42.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately upgrade all Frappe LMS instances to version 2.42.0 or later to remediate the vulnerability. Until upgrades are completed, administrators should restrict access to the Job Form to trusted users only and monitor for suspicious input or unusual activity. Implementing web application firewalls (WAFs) with custom rules to detect and block JavaScript injection attempts in form fields can provide temporary protection. Additionally, enforcing strong authentication mechanisms and session management policies reduces the risk of attacker account misuse. Regular security audits and user training on recognizing suspicious job postings can help mitigate social engineering risks. Organizations should also review and sanitize all user-generated content before display, applying context-aware output encoding to prevent XSS. Finally, monitoring logs for anomalous behavior related to job postings and user sessions can aid in early detection of exploitation attempts.

Description

CVE-2025-67734 is a medium-severity cross-site scripting (XSS) vulnerability in the Frappe Learning Management System (LMS) versions prior to 2.42.0. Authenticated attackers can inject malicious JavaScript code via the Company Website field in the Job Form. This script executes in the browsers of users who view the affected job postings, potentially compromising user data or session integrity. The vulnerability requires attacker authentication but no user interaction beyond viewing the malicious content. It has a CVSS score of 5.1, reflecting moderate impact and ease of exploitation. The issue is resolved in version 2.42.

References

Community reviews

Loading reviews…