Skip to main content
VulnerabilityPublished Updated

CVE-2025-68161: Apache Log4j Core · Improper Validation of Certificate with Host Mismatch

Affects Apache Log4j CoreSource CVE Database V5

0

Not known to be exploited · CVSS 6.3 Medium : upgrade to 2.25.3 when convenient.

Data as of 26 Oct 2026, 09:15 UTC

CVSS 4.0 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.25.3
CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade org.apache.logging.log4j/log4j-core to 2.25.3.

Affected software

ProductAffectedFixed in
Mavenorg.apache.logging.log4j/log4j-corepkg:maven/org.apache.logging.log4j/log4j-coreOther threatsAffected
  • =2.0-beta9
  • =3.0.0-alpha1
  • <2.25.3
Fixed in
  • 2.25.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Apache Log4j Core to version 2.25.3, which contains the official fix for this vulnerability. Alternatively, configure the Socket Appender to use a private or restricted trust root to limit the set of trusted certificates. Patch status is confirmed by the vendor advisory. No other mitigations are indicated.

Description

Apache Log4j Core versions 2.0-beta9 through 2.25.2 contain a vulnerability in the Socket Appender where TLS hostname verification is not properly performed, even if configured to do so. This flaw can allow a man-in-the-middle attacker to intercept or redirect log traffic if they can present a trusted certificate and intercept network traffic. The issue is addressed in version 2.25.3. Users can alternatively mitigate by restricting the trust root to limit trusted certificates.

References

Community reviews

Loading reviews…