Skip to main content
VulnerabilityPublished

CVE-2025-68637: Apache Uniffle · Improper Validation of Certificate with Host Mismatch

Affects Apache UniffleSource CVE Database V5

0

Not known to be exploited · CVSS 9.1 Critical : upgrade to 0.10.0 as a priority.

Data as of 26 Oct 2026, 15:59 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.10.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Apache Uniffle and org.apache.uniffle/uniffle to 0.10.0.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache UniffleAffected
  • <0.10.0
Fixed in
  • 0.10.0
Mavenorg.apache.uniffle/unifflepkg:maven/org.apache.uniffle/uniffleOther threatsAffected
  • <0.10.0
Fixed in
  • 0.10.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The primary mitigation is to upgrade Apache Uniffle to version 0.10.0 or later, where proper SSL certificate validation and hostname verification are enforced by default. Until the upgrade can be applied, organizations should implement network-level protections such as enforcing strict TLS inspection policies, deploying network segmentation to isolate Uniffle components, and using VPNs or secure tunnels to protect REST API traffic. Additionally, administrators should audit existing configurations to ensure no overrides disable hostname verification or trust all certificates. Monitoring network traffic for anomalous SSL certificates or unexpected connections to Uniffle Coordinator services can help detect potential MITM attempts. Incorporating certificate pinning or mutual TLS authentication, if supported, can further harden communications. Finally, organizations should review and update incident response plans to address potential exploitation scenarios involving data interception or manipulation in distributed systems.

Description

CVE-2025-68637 is a critical vulnerability in Apache Uniffle versions prior to 0.10.0 where the HTTP client disables hostname verification and trusts all SSL certificates by default. This misconfiguration allows attackers to perform Man-in-the-Middle (MITM) attacks on REST API communications between the Uniffle CLI/client and the Uniffle Coordinator service. The vulnerability has a CVSS score of 9.1, indicating high severity with potential for complete confidentiality and integrity compromise without requiring authentication or user interaction. Upgrading to version 0.10.0 mitigates this issue by enforcing proper certificate validation. European organizations using Apache Uniffle, especially in data-intensive or distributed computing environments, should prioritize patching to prevent interception or manipulation of sensitive data.

References

Community reviews

Loading reviews…