CVE-2025-68703: samrocketman jervis · Inadequate Encryption Strength
Affects samrocketman jervisSource CVE Database V5
Not known to be exploited · CVSS 8.7 High : upgrade to 2.2 soon.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 2% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 13 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade jervis and samrocketman/jervis to 2.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| samrocketmanjervis | Affected
| Fixed in
|
GitHubsamrocketman/jervispkg:github/samrocketman/jervisOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
The primary mitigation is to upgrade the jervis library to version 2.2 or later, where the salt derivation method has been corrected to ensure unique and unpredictable salts for each encryption operation. Organizations should audit their Jenkins environments to identify any usage of jervis versions below 2.2 and prioritize patching. Additionally, review and enhance encryption key management practices to avoid deterministic key derivation. Implement monitoring and alerting on Jenkins pipeline activities to detect unusual access or encryption-related anomalies. Restrict network access to Jenkins servers to trusted IPs and enforce strong authentication and authorization controls to limit potential exploitation vectors. Consider rotating any secrets or credentials that may have been encrypted with vulnerable keys. Finally, incorporate cryptographic best practices in pipeline scripts and shared libraries to prevent similar weaknesses.
Description
CVE-2025-68703 is a high-severity vulnerability in the samrocketman jervis library used for Job DSL plugin scripts and Jenkins pipeline libraries. Versions prior to 2.2 derive the encryption salt from a sha256 hash of the passphrase, causing identical keys to be generated for the same password across encryption operations. This inadequate encryption strength (CWE-326) can lead to predictable encryption keys, weakening confidentiality protections. The vulnerability requires no authentication or user interaction and can be exploited remotely. It has a CVSS 4.0 score of 8.7, indicating high severity. The issue is fixed in version 2.2 of jervis.