CVE-2025-68931: samrocketman jervis · Improper Authentication
Affects samrocketman jervisSource CVE Database V5
Not known to be exploited · CVSS 8.7 High : upgrade to 2.2 soon.
Data as of 26 Oct 2026, 08:30 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 13 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade jervis and samrocketman/jervis to 2.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| samrocketmanjervis | Affected
| Fixed in
|
GitHubsamrocketman/jervispkg:github/samrocketman/jervisOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
1. Upgrade all instances of the jervis library to version 2.2 or later immediately to apply the fix that adds proper authentication to the encryption process. 2. 3. Replace AES/CBC/PKCS5Padding encryption with authenticated encryption modes such as AES-GCM or AES-CCM if custom encryption is implemented outside of jervis. 4. Implement strict access controls and monitoring on Jenkins environments to detect unusual pipeline activity or unauthorized access attempts. 5. Review and rotate any secrets or credentials that may have been encrypted with vulnerable jervis versions to prevent misuse if data was compromised. 6. Educate DevOps and security teams about the risks of improper cryptographic practices and encourage use of vetted libraries with authenticated encryption. 7. Consider deploying runtime application self-protection (RASP) or endpoint detection tools to identify exploitation attempts targeting Jenkins pipelines. 8. Maintain an inventory of all Jenkins plugins and libraries to ensure timely updates and vulnerability management.
Description
CVE-2025-68931 is a high-severity vulnerability affecting versions of the samrocketman jervis library prior to 2.2. The issue arises from the use of AES encryption in CBC mode with PKCS5 padding without proper authentication, making it vulnerable to padding oracle attacks and ciphertext manipulation. This improper authentication flaw (CWE-287) combined with weak cryptographic usage (CWE-327) allows attackers to decrypt or alter encrypted data without authorization. The vulnerability requires no authentication or user interaction and can be exploited remotely, posing a significant risk to confidentiality and integrity. The flaw is fixed in version 2.2 of jervis. European organizations using Jenkins pipelines or Job DSL scripts that incorporate jervis versions before 2.2 could face data compromise or pipeline manipulation. Mitigation involves upgrading to jervis 2.