Skip to main content
VulnerabilityPublished

CVE-2025-69200: thorsten phpMyFAQ · Exposure of Sensitive Information Through Data Queries

Affects thorsten phpMyFAQSource CVE Database V5

0

Not known to be exploited · public detection template (Nuclei) · CVSS 7.5 High : upgrade to 4.0.16 soon.

Data as of 26 Oct 2026, 09:15 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
2.1% chance of exploitation in 30 days – higher than 81% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.0.16
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Dec 2025

  2. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade thorsten/phpMyFAQ to 4.0.16.

Affected software

ProductAffectedFixed in
GitHubthorsten/phpMyFAQpkg:github/thorsten/phpMyFAQOther threatsAffected
  • <4.0.16
Fixed in
  • 4.0.16

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should immediately upgrade all phpMyFAQ installations to version 4.0.16 or later to remediate this vulnerability. Until upgrades can be applied, organizations should implement strict network-level access controls to restrict access to the /api/setup/backup endpoint, ideally limiting it to trusted administrative IP addresses only. Web server configurations should be reviewed to prevent direct access to backup files or directories where such archives might be stored. Monitoring and logging of access to backup-related endpoints should be enabled to detect any suspicious activity. Additionally, organizations should audit their phpMyFAQ configurations and remove any unnecessary backup files from web-accessible locations. Regular vulnerability scanning and penetration testing should include checks for this vulnerability. Finally, organizations should review database credentials and rotate them if there is any suspicion of compromise due to this vulnerability.

Description

phpMyFAQ is an open source FAQ web application. In versions prior to 4.0.16, an unauthenticated remote attacker can trigger generation of a configuration backup ZIP via `POST /api/setup/backup` and then download the generated ZIP from a web-accessible location. The ZIP contains sensitive configuration files (e.g., `database.php` with database credentials), leading to high-impact information disclosure and potential follow-on compromise. Version 4.0.16 fixes the issue.

References

Community reviews

Loading reviews…