CVE-2025-8259: Vaelsys VaelsysV4 · OS Command Injection
Affects Vaelsys VaelsysV4Source CVE Database V5
Not known to be exploited · CVSS 6.9 Medium.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 3.1% chance of exploitation in 30 days – higher than 87% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 28 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubvaelsys/vaelsysv4pkg:github/vaelsys/vaelsysv4Other threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade affected VaelsysV4 installations to version 5.1.1 or 5.4.1 as these versions contain the official fix for this vulnerability. No other mitigations are specified or required once patched. Until upgrade, restrict access to the vulnerable web interface to trusted networks if possible to reduce exposure.
Description
A vulnerability was identified in Vaelsys VaelsysV4 up to 5.1.0/5.4.0. Affected by this issue is the function execute_DataObjectProc of the file /grid/vgrid_server.php of the component Web interface. Such manipulation of the argument xajaxargs leads to os command injection. The attack can be executed remotely. The exploit is publicly available and might be used. Upgrading to version 5.1.1 and 5.4.1 can resolve this issue. It is suggested to upgrade the affected component.
References
- vuldb.com/vuln/317847 (opens in a new tab)
- vuldb.com/vuln/317847/cti (opens in a new tab)
- vuldb.com/submit/616920 (opens in a new tab)
- github.com/waiwai24/0101/blob/main/CVEs/Vaelsys/Remote_Code_Execution_in_Vaelsys_V4_Platform.md (opens in a new tab)
- vaelsys.github.io/security-advisory/advisories/VSEC_V4_2025_07_0001.html (opens in a new tab)