CVE-2025-8714: PostgreSQL · Untrusted Functionality Inclusion
Affects PostgreSQLSource CVE Database V5
Mentioned vulnerabilities
Not known to be exploited · CVSS 8.8 High.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 14 Aug 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PostgreSQL | Affected
| Fixed in– |
AI-suggested
- Immediately upgrade PostgreSQL to the fixed versions: 17.6, 16.10, 15.14, 14.19, or 13.22 or later.
- Avoid restoring database dumps from untrusted or unknown sources.
- Implement strict access controls to limit superuser privileges on the origin PostgreSQL server to trusted administrators only.
- Use secure channels and integrity verification (e.g., cryptographic signatures) for transferring dump files to ensure authenticity and integrity.
- Educate database administrators and users about the risks of restoring dumps from unverified sources and enforce policies requiring validation before restore.
- Monitor and audit restore activities for unusual or unauthorized operations.
- Consider isolating client systems used for restore operations to minimize impact in case of exploitation.
- Review and restrict psql meta-command usage in automated restore scripts where feasible.
- Stay informed about any emerging exploits or patches related to this vulnerability.
Description
Untrusted data inclusion in pg_dump in PostgreSQL allows a malicious superuser of the origin server to inject arbitrary code for restore-time execution as the client operating system account running psql to restore the dump, via psql meta-commands.pg_dumpall is also affected.pg_restore is affected when used to generate a plain-format dump. This is similar to MySQL CVE-2024-21096. Versions before PostgreSQL 17.6, 16.10, 15.14, 14.19, and 13.22 are affected.