Skip to main content
VulnerabilityPublished Updated

CVE-2026-0562: parisneo/lollms · Incorrect Authorization

Affects parisneo/lollmsSource CVE Database V5

0

Not known to be exploited · CVSS 8.3 High : upgrade to 2.2.0 soon.

Data as of 26 Oct 2026, 13:47 UTC

CVSS 3.0 base score
8.3High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.2.0
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade parisneo/lollms to 2.2.0.

Affected software

ProductAffectedFixed in
parisneoparisneo/lollmsAffected
  • ≥ unspecified, < 2.2.0
Fixed in–
GitHubparisneo/lollmspkg:github/parisneo/lollmsOther threatsAffected
  • <2.2.0
Fixed in
  • 2.2.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix for this vulnerability is available in parisneo/lollms version 2.2.0. Users and administrators should upgrade to version 2.2.0 or later to remediate this issue. Since this is not a cloud service, manual patching is required. There are no indications of known exploits in the wild at this time.

Description

A critical security vulnerability in parisneo/lollms versions up to 2.2.0 allows any authenticated user to accept or reject friend requests belonging to other users. The `respond_request()` function in `backend/routers/friends.py` does not implement proper authorization checks, enabling Insecure Direct Object Reference (IDOR) attacks. Specifically, the `/api/friends/requests/{friendship_id}` endpoint fails to verify whether the authenticated user is part of the friendship or the intended recipient of the request. This vulnerability can lead to unauthorized access, privacy violations, and potential social engineering attacks. The issue has been addressed in version 2.2.0.

References

Community reviews

Loading reviews…