Skip to main content
CVE-2026-0719VulnerabilityPublished Updated

CVE-2026-0719: Red Hat Enterprise Linux 10 · Stack-based Buffer Overflow

Affects Red Hat Enterprise Linux 10Source CVE Database V5

0

Not known to be exploited · CVSS 8.6 High : upgrade to 9.2.10 or 8.8.8 soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.2.10, 8.8.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade redhat/libsoup to 9.2.10 or 8.8.8.

Affected software

ProductAffectedFixed in
Red HatRed Hat Enterprise Linux 10Affected–Fixed in–
Red HatRed Hat Enterprise Linux 10.0 Extended Update SupportAffected–Fixed in–
Red HatRed Hat Enterprise Linux 7 Extended Lifecycle SupportAffected–Fixed in–
Red HatRed Hat Enterprise Linux 8Affected–Fixed in–
Red HatRed Hat Enterprise Linux 8Affected–Fixed in–
Red HatRed Hat Enterprise Linux 8.2 Advanced Update SupportAffected–Fixed in–
Red HatRed Hat Enterprise Linux 8.2 Advanced Update SupportAffected–Fixed in–
Red HatRed Hat Enterprise Linux 8.4 Advanced Mission Critical Update SupportAffected–Fixed in–
Red HatRed Hat Enterprise Linux 8.4 Advanced Mission Critical Update SupportAffected–Fixed in–
Red HatRed Hat Enterprise Linux 8.4 Extended Update Support Long-Life Add-OnAffected–Fixed in–
Red HatRed Hat Enterprise Linux 8.4 Extended Update Support Long-Life Add-OnAffected–Fixed in–
Red HatRed Hat Enterprise Linux 8.6 Advanced Mission Critical Update SupportAffected–Fixed in–
Red HatRed Hat Enterprise Linux 8.6 Advanced Mission Critical Update SupportAffected–Fixed in–
Red HatRed Hat Enterprise Linux 8.6 Telecommunications Update ServiceAffected–Fixed in–
Red HatRed Hat Enterprise Linux 8.6 Telecommunications Update ServiceAffected–Fixed in–
Red HatRed Hat Enterprise Linux 8.6 Update Services for SAP SolutionsAffected–Fixed in–
Red HatRed Hat Enterprise Linux 8.6 Update Services for SAP SolutionsAffected–Fixed in–
Red HatRed Hat Enterprise Linux 8.8 Telecommunications Update ServiceAffected–Fixed in–
Red HatRed Hat Enterprise Linux 8.8 Telecommunications Update ServiceAffected–Fixed in–
Red HatRed Hat Enterprise Linux 8.8 Update Services for SAP SolutionsAffected–Fixed in–
Red HatRed Hat Enterprise Linux 8.8 Update Services for SAP SolutionsAffected–Fixed in–
Red HatRed Hat Enterprise Linux 9Affected–Fixed in–
Red HatRed Hat Enterprise Linux 9.0 Update Services for SAP SolutionsAffected–Fixed in–
Red HatRed Hat Enterprise Linux 9.2 Update Services for SAP SolutionsAffected–Fixed in–
Red HatRed Hat Enterprise Linux 9.4 Extended Update SupportAffected–Fixed in–
Red HatRed Hat Enterprise Linux 9.6 Extended Update SupportAffected–Fixed in–
Red HatRed Hat OpenShift Dev Spaces (RHOSDS) 3.26Affected–Fixed in–
Red HatRed Hat OpenShift Dev Spaces (RHOSDS) 3.26Affected–Fixed in–
Red HatRed Hat OpenShift Dev Spaces (RHOSDS) 3.26Affected–Fixed in–
Red HatRed Hat Enterprise Linux 6Affected–Fixed in–
Red Hatredhat/libsouppkg:rpm/redhat/libsoupOther threatsAffected
  • >=8.8 <8.8.8
  • >=9.2 <9.2.10
Fixed in
  • 8.8.8
  • 9.2.10

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released official security updates that fix this vulnerability in libsoup for Red Hat Enterprise Linux 8.8 and 9.2. Users should apply the updates as described in Red Hat advisories RHSA-2026:1948 and RHSA-2026:2005. Patch availability is confirmed and remediation is via official fixes. No additional mitigation actions are required beyond applying these updates.

Description

A flaw was identified in the NTLM authentication handling of the libsoup HTTP library, used by GNOME and other applications for network communication. When processing extremely long passwords, an internal size calculation can overflow due to improper use of signed integers. This results in incorrect memory allocation on the stack, followed by unsafe memory copying. As a result, applications using libsoup may crash unexpectedly, creating a denial-of-service risk.

References

Community reviews

Loading reviews…