CVE-2026-0943: JV HarfBuzz::Shaper · Dependency on Vulnerable Third-Party Component
Affects JV HarfBuzz::ShaperSource CVE Database V5
Mentioned vulnerabilities
Not known to be exploited · CVSS 7.5 High : upgrade to 0.032 soon.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.032
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 19 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade HarfBuzz::Shaper and HarfBuzz-Shaper to 0.032.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| JVHarfBuzz::Shaper | Affected
| Fixed in
|
GitHubHarfBuzz-Shaperpkg:github/HarfBuzz-ShaperOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
- Upgrade HarfBuzz::Shaper to version 0.032 or later, which includes an updated HarfBuzz library that addresses the null pointer dereference vulnerability.
- Audit all software dependencies to identify bundled or linked versions of HarfBuzz 8.4.0 or earlier and update them accordingly.
- Implement runtime protections such as application-level monitoring and crash detection to quickly identify and respond to denial of service conditions.
- Employ network-level protections like rate limiting and anomaly detection to mitigate potential exploitation attempts.
- For organizations unable to immediately upgrade, consider isolating affected services or applying temporary workarounds such as input validation or disabling vulnerable features if feasible.
- Maintain an inventory of all Perl modules and third-party libraries to improve supply chain visibility and facilitate rapid response to similar vulnerabilities. 7.
Description
CVE-2026-0943 is a high-severity vulnerability in HarfBuzz::Shaper versions prior to 0.032 for Perl, caused by a null pointer dereference in a bundled HarfBuzz library (version 8.4.0 or earlier). This flaw leads to a denial of service (DoS) condition without requiring authentication or user interaction. The vulnerability stems from a dependency on a vulnerable third-party component, specifically HarfBuzz affected by CVE-2026-22693. Although no known exploits are currently in the wild, the vulnerability's ease of remote exploitation and impact on availability make it a significant risk. European organizations using affected versions in their software stacks, especially those relying on Perl bindings for text shaping or rendering, should prioritize patching or mitigating this issue. Countries with strong software development sectors and extensive use of open-source libraries are more likely to be impacted. Immediate mitigation involves updating to HarfBuzz::Shaper version 0.