CVE-2026-0949: EnterpriseDB Postgres Enterprise Manager (PEM) · Cross-site Scripting
Affects EnterpriseDB Postgres Enterprise Manager (PEM)Source CVE Database V5
Not known to be exploited · CVSS 6.5 Medium.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 16 Jan 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| EnterpriseDBPostgres Enterprise Manager (PEM) | Affected
| Fixed in– |
AI-suggested
European organizations should immediately upgrade PEM to version 9.8.1 or later, where the vulnerability is patched. Until patching is possible, restrict access to the Manage Charts menu strictly to trusted administrators and monitor for unusual activity. Implement strict role-based access controls (RBAC) to minimize the number of users with pem_admin or pem_super_admin privileges. Conduct regular audits of user privileges and review chart configurations for suspicious or unauthorized scripts. Employ Content Security Policy (CSP) headers to limit the execution of unauthorized scripts in the PEM web interface. Additionally, educate administrators about the risks of injecting untrusted input and encourage safe handling of chart creation. Network segmentation and monitoring of PEM traffic can help detect exploitation attempts. Finally, maintain up-to-date backups and incident response plans to quickly recover from potential compromises.
Description
PEM versions prior to 9.8.1 are affected by a stored Cross-site Scripting (XSS) vulnerability that allows users with access to the Manage Charts menu to inject arbitrary JavaScript when creating a new chart, which is then executed by any user accessing the chart. By default only the superuser and users with pem_admin or pem_super_admin privileges are able to access the Manage Charts menu.