CVE-2026-106456: backstage · Incorrect Authorization
Affects backstageSource GCVE Database
Not known to be exploited · CVSS 4.8 Medium : upgrade to 1.55.0 when convenient.
Data as of 27 Oct 2026, 21:15 UTC
- Patch
- Available – fixed in 1.55.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade backstage to 1.55.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| backstage backstage | Affected
| Fixed in
|
AI-suggested
Upgrade Backstage to version 1.55.0 or later, where this authorization issue is fixed. No other mitigations or temporary workarounds are indicated by the vendor advisory. Applying the official fix fully resolves the vulnerability.
Description
CVE-2026-106456 is an authorization vulnerability in the Backstage open framework affecting the @backstage/plugin-proxy-backend package versions from 0.5.0 up to 0.6.18. The issue arises from inconsistent credential enforcement when overlapping proxy routes are configured with different authentication requirements. Specifically, if a parent proxy path allows unauthenticated access while a nested path requires credentials, the unauthenticated exemption from the parent path can incorrectly apply to the nested path. This allows unauthenticated users to access nested upstream services, potentially using static credentials configured for that proxy. The vulnerability is fixed in version 0.6.18.