CVE-2026-106458: backstage · Incorrect Authorization
Affects backstageSource GCVE Database
Not known to be exploited · CVSS 6.5 Medium : upgrade to 0.5.15 when convenient.
Data as of 27 Oct 2026, 21:15 UTC
- Patch
- Available – fixed in 0.5.15
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade @backstage/plugin-catalog-backend-module-bitbucket-server to 0.5.15.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
npm@backstage/plugin-catalog-backend-module-bitbucket-serverpkg:npm/@backstage/plugin-catalog-backend-module-bitbucket-serverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade the @backstage/plugin-catalog-backend-module-bitbucket-server package to version 0.5.15 or later, where the issue is fixed. No other mitigation is indicated by the vendor advisory.
Description
CVE-2026-106458 is an authorization vulnerability in the Backstage open framework affecting the @backstage/plugin-catalog-backend-module-bitbucket-server package versions from 0.4.0 up to 0.5.15. The issue involves inconsistent filtering of Bitbucket Server repositories during event-driven catalog updates, allowing an authenticated user with push access to a filtered-out repository to cause the system to ingest catalog locations from that repository despite it being excluded by configured filters. This could lead to unauthorized inclusion of repository data in the catalog. The vulnerability is fixed in version 0.5.15.